Drupal 7 is almost stable. You maybe tempted to download it now and install it. By all means do! its great! But if you're installing Drupal on a PostgreSQL database, you'll run into a message like this:

"The version of PHP you are using has known issues with PostgreSQL. You can see more at http://drupal.org/node/515310. We suggest you upgrade PHP to 5.2.11, 5.3.1 or greater. Failing to do so may result in serious data corruption later."

So what is this? Should you be worried? At this stage, the answer is no. In fact, in most situations, the answer is still no. Why is that you ask? The "known issues" are actually issues with the PHP PDO driver that Drupal 7 uses to connect to the database with and the way PHP deals with integers beyond its capacity. Let me explain.

See, PHP has a default constant called PHP_INT_MAX. The value of this constant is the highest number PHP can store in memory as an integer. This varies between 32 and 64 bit systems (its a lot higher in 64-bit systems). When PHP executes a program that uses a int value higher than PHP_INT_MAX, PHP converts the int to a string and stores the value as a float.

Now here is where the tricky bit comes in. PostgreSQL will let you insert a number into an INT column represented like so: 123, '123', 12.3 but not '12.3'. And that is the problem. When PDO tries to pass an INT higher than PHP_INT_MAX to PostgreSQL, it passes it as a float in a string. The end result is, PostgreSQL spits a syntax error and issues will start to occur in your app.

For example, if this number happens to be your primary key column in your table. Updating and deleting rows past PHP_INT_MAX will become impossible with Drupal.

Fortunately, the problem was fixed in PHP 5.2.11 and 5.3.1 however, many distros such as Debian Lenny or Ubuntu Karmic, still use this unpatched version of PHP.

While I would recommend upgrading PHP, for development or smallish sites, this bug is not a problem.